MSP NETPROTECT / TOOLS

Subnet Mask Cheat Sheet

IPv4 și IPv6, într-un singur loc. Calculează intervale de adrese și consultă tabelele de prefixe.

CALCULATOR IPv4

Înțelege rețeaua.

IPv4 / CIDR

Masca potrivită, dintr-o privire.

Apasă pe un prefix pentru a-l folosi în calculator.

Referință IPv4: prefix, mască, wildcard și capacitate
CIDRMască de subrețeaWildcardAdrese totaleHosturi utilizabile
255.255.255.2550.0.0.011 · host
255.255.255.2540.0.0.122 · P2P
255.255.255.2520.0.0.342
255.255.255.2480.0.0.786
255.255.255.2400.0.0.151614
255.255.255.2240.0.0.313230
255.255.255.1920.0.0.636462
255.255.255.1280.0.0.127128126
255.255.255.00.0.0.255256254
255.255.254.00.0.1.255512510
255.255.252.00.0.3.2551.0241.022
255.255.248.00.0.7.2552.0482.046
255.255.240.00.0.15.2554.0964.094
255.255.224.00.0.31.2558.1928.190
255.255.192.00.0.63.25516.38416.382
255.255.128.00.0.127.25532.76832.766
255.255.0.00.0.255.25565.53665.534
255.254.0.00.1.255.255131.072131.070
255.252.0.00.3.255.255262.144262.142
255.248.0.00.7.255.255524.288524.286
255.240.0.00.15.255.2551.048.5761.048.574
255.224.0.00.31.255.2552.097.1522.097.150
255.192.0.00.63.255.2554.194.3044.194.302
255.128.0.00.127.255.2558.388.6088.388.606
255.0.0.00.255.255.25516.777.21616.777.214
254.0.0.01.255.255.25533.554.43233.554.430
252.0.0.03.255.255.25567.108.86467.108.862
248.0.0.07.255.255.255134.217.728134.217.726
240.0.0.015.255.255.255268.435.456268.435.454
224.0.0.031.255.255.255536.870.912536.870.910
192.0.0.063.255.255.2551.073.741.8241.073.741.822
128.0.0.0127.255.255.2552.147.483.6482.147.483.646
0.0.0.0255.255.255.2554.294.967.2964.294.967.294

Adrese totale ≠ hosturi utilizabile

Pentru /0–/30, calculul uzual scade adresa rețelei și broadcast-ul. /31 are două hosturi pe o legătură point-to-point; /32 reprezintă o singură adresă. Numerele sunt teoretice: intervalele speciale, regulile operatorului și rezervările unei platforme cloud pot limita adresele utilizabile.

Referințe tehnice: RFC 1878 ↗ · RFC 3021 ↗

IPv6 / 128 BIT

Planifică prefixele IPv6.

Calculează intervalul de adrese și numărul de subrețele. Tabelul de referință urmează structura IPv6 Chart de la RIPE NCC.

/48 → /6465 536subrețele /64 într-un /48
CALCULATOR IPv6

De la prefix la subrețele.

RIPE NCC / IPv6 CHART

Câte subrețele încap?

Prefixe /24–/64, ca în documentul de referință. Apasă un prefix pentru a-l aplica în calculator. „Biți rămași” = 128 − prefix.

Număr de blocuri /48, /56 și /64 în fiecare prefix IPv6
PrefixBlocuri /48Blocuri /56Blocuri /64Biți rămași
16M4G1T104
8M2G512G103
4M1G256G102
2M512M128G101
1M256M64G100
512K128M32G99
256K64M16G98
128K32M8G97
64K16M4G96
32K8M2G95
16K4M1G94
8K2M512M93
4K1M256M92
2K512K128M91
1K256K64M90
512128K32M89
25664K16M88
12832K8M87
6416K4M86
328K2M85
164K1M84
82K512K83
41K256K82
2512128K81
125664K80
—12832K79
—6416K78
—328K77
—164K76
—82K75
—41K74
—251273
—125672
——12871
——6470
——3269
——1668
——867
——466
——265
——164

K = 1 024 · M = 1 048 576 · G = 1 073 741 824 · T = 1 099 511 627 776
Abrevieri în baza 2, în notația RIPE NCC; valorile complete apar la trecerea peste numere. „—” înseamnă că un bloc de acea mărime nu încape în prefix.

128 de biți. Notație hexadecimală.

O adresă completă are 8 grupuri a câte 16 biți. Zerourile inițiale se pot omite; :: comprimă o singură secvență de grupuri zero.

Prefixe, fără broadcast.

IPv6 folosește lungimea prefixului, de exemplu /64. Nu are adrese broadcast; funcțiile lor sunt preluate de multicast. Nu folosim formula IPv4 „total − 2”.

/64 · /127 · /128

/64 este uzual pentru rețele LAN cu autoconfigurare. /127 este folosit pe legături point-to-point între routere. /128 reprezintă o singură adresă.

Sursă pentru tabel: RIPE NCC — IPv6 Chart. Referințe tehnice: RFC 4291 ↗ · RFC 5952 ↗ · RFC 6164 ↗

MSP NETPROTECT

De la calcule la infrastructură.

Te ajutăm să dimensionezi storage-ul și să proiectezi rețeaua companiei.

Discută cu echipa